Mac vs Windows, now we know.... (BD-Design)

by GC @, Netherlands, Sunday, April 10, 2005, 20:32 (4669 days ago)

Hi all,

Being a Mac-user since 1987, and being owner of a pair of DIY Oris horns with AER MD1 drivers, I followed all topics about Mac vs Windows on this forum with more than normal interest. So when Bert asked if someone would like to come and compare, I thought it would be a nice reason to go to Bert, listen to his new things and compare my Mac to the Windows system Bert uses. Problem was that my Mac (Powerbook G4 titanium 400 MHz, 2001) does not support USB2.0, needed for the twindac. I bought a PCI card with 2 USB2.0 outputs (59 euro) to solve this little problem.
More things I arranged in advance: I downloaded the latest version of iTunes, made some space on the only 10 gig harddisk and ripped 3 CD's to AIFF format
Last friday I drove to Bert to compare. Bert's laptop had a broken USB port, so he ripped the CD's I took there on his Windos PC in a few minutes. We made the same playlist on both the Mac and the PC
and started listening to the PC. Not new for Bert, but I was surprised by the sound, being clear, transparant, with a wide and deep stage, things I can reach at home only with certain vinyl records.
after about 20 minutes we switched to the Mac. Soon we were sure that, although the sound was not bad at all, it did not reach the level of the PC. It sounded a bit dull, flat. Bert suggested to try an other format, so I put some tracks on the Mac in WAV format. Listening again. Although better than the AIFF format we still could hear the difference very well. The soundstage being not as wide and not as deep as the PC. You could hear less of the environment on the Mac, the voice of the singer comming from below in stead of from the middle, it missed the feeling of being there.
To make a real fair test we finaly put my PCI card in Bert's PC laptop, so this computer could be connected to the twindac. Listenig again made sure that the PCI card was not the bottleneck. It even sounded a little better than the PC we started with. So, sorry for me and all other Mac-users:
Mac with iTunes does not sound as good as a WIndows PC configured the way Bert did.
The promblem seems to be that there is no way to configure the Mac/I tunes. Window-users can ajust the amount of memory used, overrule the volume adjustment and so on. On a Mac I at least am not able to. Maybe someone can write/program a Mac-application that lets you configure these things. (What you want in fact is a player that uses as much memory as possible and sends the digital data direct to the USB2.0 port without any interference). Maybe linux offers a possibility ?...

cheers, Werner

Tags:
0

Mac vs Windows, now we know....

by GC, Monday, April 11, 2005, 00:01 (4669 days ago) @ GC

Hi Werner,

Thank you for the experiment! I was always curious about the differences between the two... :)

I played around with the Windows configuration options a bit more and it seems to be more simple to configure than I thought.

Not easy to teach though (I made some screen shots to make things more clear). The basic way to disable software/hardware is done easy by simply disabling the audio properties of the USB DAC (and Sound Card). All mixer functions, volume control, etc. are then not active anymore (and not in the "way").

First go to the properties settings window (the pictures shown below are in Dutch but it should look equal on all Windows machines/languages) and open the sound options:

[img]images/uploaded/image33.jpg[/img]

Next click on hardware and then select the device you want to configure as shown on the picture below. Do check the other devices like "MIDI", "mixer" and "line" within the same window, all functions should be disabled.

[img]images/uploaded/image34.jpg[/img]

After changing the configuration then do restart the computer...

This is just to optimise Windows standard configuration, settings for Foobar are equally important. No time left at this moment to explain that... first let us see if you are able to change Windows as discribed above and first listen to these changes...

Ciao,

Bert

Tags:
0

Mac vs Windows, now we know....

by GC, Monday, April 11, 2005, 01:01 (4669 days ago) @ GC

Thanks Bert, I'll give it a try...

Tags:
0

Mac vs Windows, now we know....

by GC, Monday, April 11, 2005, 23:22 (4668 days ago) @ GC

Yep, switched off the USB audio option and big improvement, this is what it looks like in English:

[img]images/uploaded/image37.jpg[/img]

Tags:
0

Mac vs Windows, now we know....

by GC, Tuesday, April 12, 2005, 00:13 (4668 days ago) @ GC

Hi Brian,

Yep, switched off the USB audio option and big improvement, this is what it
looks like in English:

Yes, it sure does sound better that way. If you're using foobar then make sure that the core and the playback priority is set to maximum priority (real-time).

If you can't make that work through the configuration of foobar then press ctrl-alt-del so that the task manager shows up. Look for foobar.exe (under the process tab) and right-click to set and check its priority there. That also brings a major improvement!

Ciao,

Bert

Tags:
0

Mac vs Windows, now we know....

by GC, Tuesday, April 12, 2005, 20:55 (4667 days ago) @ GC

Hi Bert,

If you're using foobar then make
sure that the core and the playback priority is set to maximum priority
(real-time).

...are you sure both should be max priority? I read somewhere that there was a bug in Foobar and one of the settings had to be just short of max?


Cheers,
Brian

Tags:
0

Mac vs Windows, now we know....

by GC, Tuesday, April 12, 2005, 21:18 (4667 days ago) @ GC

Hi Brian,

...are you sure both should be max priority? I read somewhere that there
was a bug in Foobar and one of the settings had to be just short of max?

I downloaded foobar a few days ago (full version) and with both settings to max seems to work well (now). At least when I check through the task manager (CTRL-ALT-DEL) then foobar is set to real-time. Before this was not the case so I guess they must have fixed that bug...

BTW, did you set the file buffer (playback settings screen) to a value higher than the tracks you play (250.000kB is more than enough for most tracks).

Ciao,

Bert

Tags:
0

Mac vs Windows, now we know....

by GC @, Amsterdam, Sunday, April 24, 2005, 23:06 (4655 days ago) @ GC

Hi Bert,

Waht is the maximum word length and the maximum sampling frequency of the USB-SPDIF convertor. I just want to play around with the upsampling features in Foobar to see what it does but I don't want to destroy any hardware with it.

At the moment my best results are with the Kernel Streaming, core and playback set to realtime and with a memory buffer of 200MB. The only small problem with the kernel streaming was that the streaming buffer can only be set to 20mS, above that the playback freezes very easy. This small buffer shouldn't be a problem though because playback is not directly from the harddrive bu from memory.

I have also compared my Mac against my PC and have found the PC to be sounding much better.

Has anyone tried to feed the USB-SPDIF convertor with it's own power supply ?

Tags:
0

Mac vs Windows, now we know....

by GC, Monday, April 25, 2005, 09:48 (4654 days ago) @ GC

Hi Sjef,

Waht is the maximum word length and the maximum sampling frequency of the
USB-SPDIF convertor. I just want to play around with the upsampling
features in Foobar to see what it does but I don't want to destroy any
hardware with it.

Its a 16-bit converter, thats all I can tell.

problem with the kernel streaming was that the streaming buffer can only be
set to 20mS, above that the playback freezes very easy. This small buffer

I never had Kernel Streaming working, probable because I have the buffer set too long I guess. I'll give it a try... :)

Has anyone tried to feed the USB-SPDIF convertor with it's own power
supply ?

I tested it with the same battery supply as used for the TwinDAC+ and found that it sounded worse. It was a modified converter though...

Ciao,

Bert

Tags:
0

Mac vs Windows, now we know....

by GC, Thursday, May 12, 2005, 13:14 (4637 days ago) @ GC

I too have found no success working with KS/FooBar/TwinDac USB.
I tried 20ms but the Foobar is not even able to open/Read the file. Would you let us know more config info?

Tags:
0

Mac vs Windows, now we know....

by GC, Thursday, May 12, 2005, 15:03 (4637 days ago) @ GC

Hi Samer,

I too have found no success working with KS/FooBar/TwinDac USB.
I tried 20ms but the Foobar is not even able to open/Read the file. Would
you let us know more config info?

I tried 20ms and it didn't work here also...

Ciao,

Bert

Tags:
0

Mac vs Windows, now we know....

by GC, Friday, May 13, 2005, 00:24 (4637 days ago) @ GC

Kernel streaming can takes over the sound device completely. That's why it can only function when there is no other software running wich makes any kind of connection to the sound device (usb/spdif convertor). When foobar is playing via kernel streaming there can be no other sound being played from other software (such as windows
itself) the sound device can only be occupied by one program at the same time (like in the bad old windows 3.1 days)

My config is as follows:

Core set to real time (KS did also work without this setting) Playback set to realtime (same comment) Output set to Kernel Streaming with buffer set to 20mS (lowest possible) Output format set to 16 bit fixed point with strong ATH noise shaping Playback thread priority set to max (= default foobar setting) Replay gain disabled (never use this one, kills dynamics) No Dsp features USB sound device drivers default by windows (I'm using win2k pro, not XP, but it should work on XP also, after all it's the same kernel)

I hope this is of some help to you, I'm not a foobar expert, I'm just fiddling around with the settings. On other systems maybe Direct Sound sounds better, I don't know but it sure will sound better than Wave Out.

All other plug-ins are just for convenience and looks, not for sound output

Tags:
0

Additional hardware configuration...

by GC, Monday, July 04, 2005, 12:15 (4584 days ago) @ GC

Hi all,

I think it was not made clear enough in the previous posts about configuring the hardware and its drivers.

The settings as described above should also be applied to the soundcard present in the computer.

If all is done right then the sound options window looks like there is no audio hardware present at all (all should look "grey" and nothing can be changed in that window).

[img]images/uploaded/image53.jpg[/img]

After restart you will not hear any Windows sounds or be able to play any sound through the soundcard. All sound will now only be heard through the USB DAC...

Ciao,

Bert

Tags:
0

RSS Feed of thread